The official website of the HHMI Science Education Alliance-Phage Hunters Advancing Genomics and Evolutionary Science program.

Welcome to the forums at Please feel free to ask any questions related to the SEA-PHAGES program. Any logged-in user may post new topics and reply to existing topics. If you'd like to see a new forum created, please contact us using our form or email us at

Phamerator not loading

| posted 21 Feb, 2022 13:30
Hi all,

Is anyone else having trouble accessing Phamerator? It started for me on Friday, and I figured it was just updating, but I still can't access this morning. Tried 2 different browsers, and it just doesn't load. I get "HTTP ERROR 502." Is it just me? I wanted to teach translational frameshifts this week, which will be tricky without Phamerator!

Nikki @ USciences
| posted 21 Feb, 2022 18:23
Not loading for me either. Also 502 error on 2 different browsers. I have sent an email to Steve.
Edited 21 Feb, 2022 18:32
| posted 21 Feb, 2022 18:50
I also tried both Firefox and Chrome. Neither worked for Phamerator. Same 502 error message.
| posted 21 Feb, 2022 19:17
Thank-you both! Hopefully someone will post soon with a solution! I wonder if I could access it the old-fashioned way in Ubuntu. If I get the chance, I'll try it and let you all know if it worked.
| posted 22 Feb, 2022 02:36
I have tried WiFi at Pitt and at home, 3 different models of Mac and 1 PC, Firefox, Safari and Chrome, none of the above can get Phamerator to load for me. The following post also discussed the 502 error, but it's not clear exactly how the issue was fixed…
| posted 22 Feb, 2022 16:35
I heard from Steve, Phamerator is now up and working for me. If it is not working for you be sure to post again.
| posted 22 Feb, 2022 16:55
I hate to be the pest but Phamerator is still not working for me. When I try to google search phamerator, the search result seems to suggest that I don't have WiFi (please see attached for the screenshot), but I actually do have a working WiFi.
Chris, is there something that you have to do from your end to get it to work?
| posted 22 Feb, 2022 17:14
Thanks everyone. It is now working on my end. I have no idea why you'd be getting a message that you don't have WiFi.

Login to post a reply.