The official website of the HHMI Science Education Alliance-Phage Hunters Advancing Genomics and Evolutionary Science program.

Welcome to the forums at Please feel free to ask any questions related to the SEA-PHAGES program. Any logged-in user may post new topics and reply to existing topics. If you'd like to see a new forum created, please contact us using our form or email us at


| posted 13 Dec, 2021 10:57
I had the same problem as Deb above. I installed DNA Master according to instructions (Version 5.23.6, Build 2705) on the desktop. I also ran it as an administrator, but upon opening the program it gives the following error right away: "Queries table is corrupt; reload from DNA Master FTP site?"

If I say "yes", then it gives the error: "Invalid file name".

If I try to open the fasta file, it gives the error: "TbCodonBias: Cannot perform this operation on a closed dataset."

Thanks for any advice!
| posted 13 Dec, 2021 17:16
My student and I are having a similar error. We both downloaded DNA Master, ran as administrator to update DNA Master, but now on trying to open an Archived file get the error message "TbQueries: Cannot perform this operation on a closed dataset". I have tried to open multiple files and keeping getting the same error.

Before running the update to DNA Master, the files were running, but without the gene numbers in Frames, and without RBS Z-score and final score.

What should we do next to allow us to open the file?

| posted 13 Dec, 2021 17:44
Hi all,
Did you go back through this forum post and unpack and repack your DNA Master file? That is the typical way to fix this.

It is tedious, so be patient.
Let me know if that corrects the problem. If not, please send me the file.
| posted 13 Dec, 2021 17:59
I haven’t even started a DNAM file. This happened immediately when I started the program for the first time on this new computer.
| posted 13 Dec, 2021 18:06
Hi. Are you running as administrator?
| posted 14 Dec, 2021 10:15
Hi Debbie, Running as an administrator has allowed me to open my file and the RBS information is now visible. Thank you, Susan
| posted 17 Dec, 2021 19:30
I haven’t even started a DNAM file. This happened immediately when I started the program for the first time on this new computer.

For future folks: Mary and I did some troubleshooting offline, and it turned out it was the folder name she'd installed DNA Master into that was giving her issues. She installed DNA Master into a folder that had an apostrophe in its name, like "Mary's Stuff", and that apostrophe was confusing DNA Master's ability to correctly locate directories and save files.

So don't use any unusual characters in the names of your filesystem, stick to letters and numbers only!

I've updated the DNA Master installation instructions to reflect this.

| posted 09 Feb, 2022 16:53
I was having Mary's error too on a new VM. I took note of Dan's message

I had no apostrophe in my path and had placed the file in a \DNA Master folder on my desktop (which had a space in there).

I decided to make things very simple. I created a C:\DNAMaster folder. I put the installation program there. I ran the installer (which was in my Downloads folder) as an administrator with that folder as the destination (and the installer wanted by default to put the program in C:\DNAMaster\DNA Master (again with the space)–but I changed it just to C:\DNAMaster and installed. Then I ran DNAmas.exe from that folder, also as an administrator. I did not the get the same errors as I did the first time (which are just like Mary's). Instead I got:

Field error (then)
Field error (then)
Data Module Error creating GenomeClipboard.db, tables

Then I updated the program. And then, it is now seeming to operate normally.

Posting this in case it is helpful to others. I am not sure if the space character in any part of my path was at fault, but I had no apostrophe or other special character in there, so I decided to try this as a last resort before asking for more help. But since it seemed to work–I'm going with it.


Kyle MacLea
Associate Professor, University of New Hampshire at Manchester +1 603-641-4129
| posted 19 Aug, 2022 14:53
I'm having the same problem. I just upgraded my MacBook to an M1 chip. I'm running Windows 11 on Parallels. I've downloaded DNA Master, the folder is on my desktop (the name is “DNA Master”. When I run the program as an administrator, it gives me an error message "Invalid File Name", which then disappears. When I try to load an existing archive file, or even just start DNA Master without a file, the "TbCodonBias: Cannot perform this operation on a closed dataset" error appears (so I can’t open the program at all). It also give the following error (most times, not every time): “Queries table is corrupt. Reload from FTP DNA Master FTP site”
I've tried uninstalling and reinstalling to a different directory, but it still defaults to the desktop. Any help would be great!
| posted 19 Aug, 2022 23:36
To the best of knowledge, DNA mater will not work on an M1 Mac.
Login to post a reply.