The official website of the HHMI Science Education Alliance-Phage Hunters Advancing Genomics and Evolutionary Science program.

Welcome to the forums at Please feel free to ask any questions related to the SEA-PHAGES program. Any logged-in user may post new topics and reply to existing topics. If you'd like to see a new forum created, please contact us using our form or email us at

Auto-annotation fix for fall 2017 and later

| posted 03 Oct, 2020 15:47
Hi All,
We are having trouble doing the autoannotation in both of our sections of SEA PHAGES this semester. All students are running DNA Master in Windows (in virtual box on Macs). I was so excited last Tuesday when all my students except for 2 had successfully installed DNa Master on their computers (usually that's our sticking point). All students failed the autoannotation with Glimmer failures or overall autoannotation failure messages. We checked and double checked DNA Master was updated and their preferences to make sure that Gene Prediction tabs and security were set up as instructed in the 2017 DNA Master Fix document (and as instructed in the Bioinformatics Guid) and yes we know the password.

I did note that every single student that struggled with autoanntoations had bought a brand new Mac before school started.

When I tried setting up preferences on some of their computers, I failed to complete an autoannotation.

Is anyone else having trouble with autoannotations?
| posted 15 Sep, 2021 19:29
Greetings, all!
I have a research student who is in the process of annotating a phage she discovered this past summer. When we did the auto-annotation, we got the genes called by Glimmer, but none called by GeneMark. We can get the GeneMark data from PECAAN, but it would be nice to have the GeneMark calls in DNA Master. We are running the most current version of DNA Master (5.23.6) and we set our Preferences to use the PBI server and we unchecked the boxes to the Glimmer and GeneMark servers. I am using a PC with Windows 10. I did have one question on the "Unlock Code" and "Password". The Word document shows an entry for the "Unlock Code" but "Password" is left blank. I tried it two ways (1) I entered the case-sensitive Unlock Code and left the Password blank and (2) I entered the same case-sensitive word in both the Unlock Code and Password. I got the same results both times–no GeneMark calls. As always, any help that anyone could provide would be much appreciated.
| posted 15 Sep, 2021 21:34
Hi Kathleen,
Would you try again? I just auto-annotated a genome and got GeneMark results. The license to use GeneMark's server seems to be dependent on use, so it is not easy to predict when we have to update it. It could have just been updated after you auto-annotated. If that is true then you will get GeneMark results when you repeat. If you don't get GeneMark results when you repeat, I am not sure what the problem is and will investigate further.
Keep me posted,
| posted 15 Sep, 2021 23:52
Thanks, Debbie! Unfortunately, I tried the auto-annotation again and it's still not working. I feel that maybe my Preferences aren't set correctly but I'm not sure what I'm doing wrong. Thanks for the offer of help; much appreciated!
| posted 16 Sep, 2021 00:25
Here is the next thing that I would like you to check/try.
Check out your auto-annotation choices. Do you have both analyses checked as int he attached photo?
Edited 16 Sep, 2021 00:29
| posted 16 Sep, 2021 20:51
I will add my experience as another datapoint to help with troubleshooting:
I too am also getting glimmer results but not GeneMark results, and I have confirmed the settings as displayed in Debbies attached picture. Very strange that one predictor would work and not the other for some users and not others.
| posted 16 Sep, 2021 21:04
Good info.
I have no idea if this will have any impact. The latest 'fix' is about active and passive FTP.
Make sure that in your preferences -> Internet setting ->Home Site that you match the setting that I have. (This is the only preference i have modified lately.)

And as another data point, I auto-annotated a new to me genome this morning and DID get GeneMark data in my auto-annotation.

| posted 16 Sep, 2021 21:12
I just talked to Christian and he suggested the simplest explanation is the Preference Settings in the Secure Connections panel are not set properly. See the attached picture for what they should look like.
Going forward, would you let me know if you still have problems what DNA master build number you are using. (The latest build that i have is 2704.) Thanks!
| posted 17 Sep, 2021 16:24
Hi all,
My last posts were misguided. It was the license problem. GeneMark is back on line!
| posted 17 Sep, 2021 19:39
Hello all,
I checked all of my preferences and they were exactly as Debbie's attachments showed, with the exception that I had checked "use active FTP protocol". When I unchecked the box, and then ran the auto-annotation after Debbie reported that GeneMark was back on line, it worked like a charm. Thanks for all of the help!
Edited 17 Sep, 2021 19:40
Login to post a reply.