Hi Amanda,

It seems that the way text is rendered in this forum changes double hyphens to a single wide one.

Try 'pip install –upgrade phamclust' with two hyphens rather than just the visible one, and see whether that fixes things.

Assuming it does, setting the clustering threshold to 0 should now yield the expected all-vs-all matrix.