The official website of the HHMI Science Education Alliance-Phage Hunters Advancing Genomics and Evolutionary Science program.

Welcome to the forums at Please feel free to ask any questions related to the SEA-PHAGES program. Any logged-in user may post new topics and reply to existing topics. If you'd like to see a new forum created, please contact us using our form or email us at

phage that crash starterator

| posted 01 Feb, 2016 04:04
Have another one. Bubbles123 crashes on Pham 68 of 104.

| posted 01 Feb, 2016 23:02
We can not get Starterator to connect to the database. We changed the server and database to match the Actino_Draft in phamerator, but we still get an error with any gene from any genome.
| posted 03 Feb, 2016 22:34
Roosevelt_Draft won't run. After numerous attempts I followed the "Read This" suggestions and cleaned out the Intermediate Files folder. Still crashed on pham 21 of 89, pham 5238. Typically it crashes on pham 39. Once or twice it has made it past that one, but it's never run to completion.

Edited 03 Feb, 2016 22:36
| posted 04 Feb, 2016 20:18
Mojorita_Draft is failing on pham 18 of 59, pham 162. Tried all the standard things.

| posted 07 Feb, 2016 01:36
I ran all 4 of the phage above on my system where I updated my own local copy of Starterator to fix a few bugs that were posted last fall. results for the 4 phage above:

Picard ran fine so it is likely it had an issue that I have already corrected. You can get the full report from this link.

bubbles123 crashed for me on 68 of 104, pham 5447. This pham is for the gene 107, right hand most gene, it is on negative strand. The gene starts 2 bases in from the end of the phage, this is a corner case which needs fixing. Exact error reported in line 220 of find_most_common_start of Error is ValueError: 0 is not in list. This is a new bug I have not seen before from starterator. Fixing and double checking the code will take time, for now I have just added temporary code to my copy of Starterator to skip that gene so I could create a full report of all the other genes. That full report is available here.

Roosevelt crashed for me on pham 31 of 89; pham number 8871. pham 8871 corresponds to gene 35. Error reported was line 98 of add_aligment in KeyError "TWAMP_Draft_33". This might be an naming error, the geneid in the pham table is SEA_TWAMP_33 not TWAMP_Draft_33". There are a cluster of gene names from several phage that start with "SEA_", not sure why but genes with names like this appear to be mis-handled. This is a new bug, like above, fixing the bug will take time. I have had starterator run and just skip gene 35. The full report without gene 35 is available here.

Mojorita was able to run fine so it is likely also caused by a bug I have already squashed. You can get the full report from this link.

I have posted bug reports for the bubbles 123 and roosevelt problems to my github issues tracker where I am keeping a running list of known bugs and possible improvements. Not sure when I will be able to get to these for permanent fixes. Thanks for all the crash reports, the program cannot get better without reports like these.
Edited 07 Feb, 2016 21:03
| posted 07 Feb, 2016 01:43
As for the total failure, hard to diagnose without specifics. If it is failing on everything then your assumption that it cannot connect to the database is probably correct. First thing to test then is to see if you can connect to the Actino_draft database with Phamerator. That will help separate database problems from starterator problems. Open phamerator and look in the preferences to make sure Actino_draft is the selected database and then see if phamerator can find recently added phages and make phage maps. Post the results of that test.
| posted 08 Feb, 2016 14:57
Thanks for the files, Chris!

| posted 09 Feb, 2016 17:50
I have tried all of the suggested fixes (checking the database, deleting intermediate files) but Starterator still crashes on Pham 11430 of WillSterrel_Draft every time I try to run it. Any suggestions would be appreciated since we start annotating it next week.
| posted 09 Feb, 2016 20:48
Copying Fred's stuff from another thread to here, where it's best addressed. Thanks for all your help with this, Chris! Hopefully we can get some of these bugs permafixed soon.

I have deleted all "Intermediate Files" folders in the cache as suggested by Dan Russell, "2. Some crashes have been fixed by deleting older files cached by starterator. These files can be found by going to your home directory, and select the menu item View -> "show hidden files"
Once you select that, you will see many more files and folders in your home directory. Open the folder .starterator and inside there is a folder called "Intermediate Files". I have fixed many crashes by deleting all files in that folder and running starterator again.

But "Andies_draft" still crashes at the same spot, stating "Startsaerator has encountered an error, please try again" as per attached snapshopt.


| posted 10 Feb, 2016 16:39
Both Andies and Willsterrel appear to have issues that have already been solved as both ran fine on my copy with my bug fixes, links to full reports below:
Full starterator report for Andies
Full starterator report for WillSterrel
Login to post a reply.