The official website of the HHMI Science Education Alliance-Phage Hunters Advancing Genomics and Evolutionary Science program.

Welcome to the forums at Please feel free to ask any questions related to the SEA-PHAGES program. Any logged-in user may post new topics and reply to existing topics. If you'd like to see a new forum created, please contact us using our form or email us at

PhamNexus on SEA-VM

| posted 17 Feb, 2021 01:18

We are still using PhamNexus on the 2017 version of the SEA-VM to generate Nexus files for input to SplitsTree. Given the recent changes to the location of the Actino_Draft database, we're having some difficulties connecting the PhamNexus platform to new versions of the database (but were able to reconnect the SEA-VM version of Phamerator to the new database). Are there any quick fixes that would allow us to query the SQL Actino_Draft database on the SEA-VM version of PhamNexus/are there any alternative methods for generating nexus files containing pham data?

Any help would be so appreciated! Thank you smile
| posted 17 Feb, 2021 16:53
The issues you are having are related to the restructuring of the database that was undertaken last fall. You will need to upgrade to a compatible version of PhamNexus. I can see that Christian in the Hatfull lab is still keeping it up to date as he posted code changes last October to make it compatible with the new database format. He will need to tell you how to update to that working version.
| posted 17 Feb, 2021 17:55

Thanks (again) Chris for alerting me to this post! At the end of last year we changed where the databases are hosted, and then I failed to update the URL in PhamNexus. I've now made the relevant changes, and at least on my local computer it appears as though the new version works.

In your SEA_VM, launch PhamNexus, then click Help > Check for Updates. It should notice that there are updates available, and prompt you to allow it to download. Once it finishes, restart PhamNexus and you should now be able to get database updates again. Assuming you've not updated the database within the last week, there should be a new database available.

The database download/update process can take a few minutes, depending on your internet speed and computer hardware. The fastest I've seen it is on my dev machine, about 15 seconds.

Hopefully, that's all there is to it! Please post a reply whatever the outcome, so I'll know whether there's additional work for me to do!
| posted 18 Feb, 2021 20:43
Looks to me like that worked, thank you so much!

For some reason, the program was no longer opening in the VM. In case it would be helpful to anyone else, I had to remove the program/master file and redownload the file from github. I was getting an error that the directory /seafaculty/home/phamnexus was 'not found' when trying to open the program, but it worked again after renaming the master file 'phamnexus' and moving it to the home folder. We downloaded the updates from Phamerator using the new database website (server 'HTTP://', using 'Actino_Draft' for the database) and now both Phamerator and PhamNexus are using Actino_Draft ver. 394 after checking for database updates in PhamNexus and entering the MySQL login info.

Thank you again!
| posted 19 Feb, 2021 12:42
Glad to have been able to help, though it sounds like you did most of the heavy lifting!

This is an alternative way of accomplishing the fresh 'installation' of PhamNexus that you did manually (won't be much help for you anymore, but hopefully will help anyone else that ends up here!). In a terminal inside the SEA_VM:

cd ~/
rm -r phamnexus
git clone

The first steps will make sure you're in the home directory, and delete the existing 'phamnexus' directory. The last step will download the repository and put it in a new folder called 'phamnexus', as opposed to the '~/Downloads/phamnexus-master' folder that happens if you download from GitHub in a web browser and then unzip.

I suspect that downloading the latest Actino_Draft.sql file from had little impact unless you also executed a command like:

mysql -u root -p Actino_Draft < /path/to/Actino_Draft.sql

This command (or a host of similar ones) would overwrite the existing Actino_Draft database with the database contained in your Actino_Draft.sql, and is exactly what PhamNexus does behind the scenes when it successfully performs database updates.
| posted 17 Feb, 2022 23:31
Hi all,

I've followed the directions above in the SEA VM to try to install Phamnexus. It appears to have been cloned and installed, but when I click on PhamNexus, nothing happens…

Not sure if it makes a difference, but I am using the version of the SEAVM downloaded here ( just a few weeks ago.

I've attached a screenshot of the VM environment. Any advice is most welcome!


(As a second issue, I also tried the above trick to "Check for Updates" in the working version of PhamNexus we have installed on our computer lab computers, and the database did not update. Any recommendations for that would also be very helpful.)
| posted 18 Feb, 2022 13:23
Good morning!

The SEA VM you downloaded is very old, so it's likely that the dependencies used by PhamNexus are not installed. Dan Russell and I are in the discussion phase of creating a new SEA VM, but it's been happening on an "as we have time" basis.

If you download this more recent SEA VM and email me directly ( I can help you make sure that the VM is set up and will run PhamNexus properly.

It will be much more difficult in the old VM because that operating system doesn't explicitly support a high enough Python3 version to actually run pdm_utils, or by extension PhamNexus.

| posted 18 Feb, 2022 16:21
Awesome! Thank you Christian. I will download the new one and email you with any questions I have.
| posted 29 Sep, 2022 01:05
Hi all,
I am trying to use PhamNexus in the 2020 SEA VM. It asks me what database I want to use. I choose one and click "yes" when asked if I want to check the Hatfull server for the newest database version. Then, I am asked for the mySQL login info, which I do not know. Can someone tell me the login info, or if I need to change a setting in the SEA VM? I previously used this installation of the SEA VM for flatfile checking and that worked okay.

Thank you!
| posted 29 Sep, 2022 15:37
if it is asking for the user name that is:

for the password use:
Login to post a reply.