The official website of the HHMI Science Education Alliance-Phage Hunters Advancing Genomics and Evolutionary Science program.

Welcome to the forums at Please feel free to ask any questions related to the SEA-PHAGES program. Any logged-in user may post new topics and reply to existing topics. If you'd like to see a new forum created, please contact us using our form or email us at

Adding Sanger Reads

| posted 05 Apr, 2016 20:40
Ok - just got some Sanger reads back on a phage that needed some finishing. I am following Dan's button pushing document which says to do the following:

"Adding Sanger Reads to a consed Assembly

1. Place the chromatogram (.ab1) files in the project’s chromat_dir.

2. Make a new file with the extension .fof (for file of filenames) and save it in the project’s edit_dir. This file should contain the exact names of the Sanger read files, one per line.

3. From the edit_dir, type consed and press Enter to launch consed.

4. In the Consed Main Window, click the Add New Reads button.

5. From the Files pane on the right, select your .fof file.

6. Click OK.

7. Once the process has finished, save the ace file."

However, when I get to step 6 I get a "512" unknown error.

Anybody have suggestions?

| posted 06 Apr, 2016 15:34
Welcome to Unix! The problem is likely one of two issues. The most common is that you have a folder in the path with a space in the name. This can be any folder in the hierarchy starting with the very top all the way to the edit_dir. If you are using the SEA virtual machine this folder path will start like thie: /home/seastudent… and then proceed with each folder down to edit_dir. If you have any spaces in the names of any of those folders Consed will fail to find the files. This is why folder names so often have underscores (i.e. edit_dir not "edit dir"smile. So check all your folder names.

The second most common issue is that the entries in the .fof file are not exactly correct or were made with the wrong text encoding. Check the .fof file paying particular attention to case. Unix is case sensitive, so File.ab1 is not the same as file.ab1. Finally, if you made the .fof file in a text editor that uses either mac or dos encoding it can be unreadable by Consed. Consed requires unix encoding.

Here is the protocol I use with my students:
1. create a new folder and put all the sequences files in that folder
2. cd to that folder in terminal
3. create the .fof file with the following command in terminal:

ls *.ab1 > reads.fof

4. you will now see another file in the folder with the reads called "reads.fof"

This reads.fof is unix encoded text file and is readable by Consed, also the computer is much better about avoiding typos. The user should open the reads.fof with a text editor and double check that the list of files looks good.

Now proceed with step two in Dan's protocol and move the .ab1 files into the chromat_dir and the reads.fof file into the edit_dir.

The above covers about 90% of the 512 errors, if neither helps you, post a followup.

| posted 06 Apr, 2016 19:27

Thanks for the information. I tried everything you mentioned, but still no luck.

I'm going to punt this one to Dan since I think he can resolve the issue quickly (and I think the answers to the sequencing questions are pretty straight forward just from a manual review).

| posted 06 Apr, 2016 20:16
Hi Lee,

Looks like that error is my fault! When I updated the consed on the VM, apparently I didn't copy all files from the old consed directory to the appropriate places. This would only affect uses of phred and phrap, which are rarely used, but would definitely be used when adding reads. To fix this on your VM, run the following commands when logged in as seafaculty, entering the password as necessary:

sudo cp /usr/local/genome_OLD/bin/phred /usr/local/genome/bin/
sudo cp /usr/local/genome_OLD/bin/phrap /usr/local/genome/bin/
sudo cp /usr/local/genome_OLD/lib/phredpar.dat /usr/local/genome/lib/

This should put the files in the appropriate places and make it work again. You're the first to discover this probably because 1) we barely do any Sanger reads any more and 2) I usually run consed on my Mac rather than within the VM.

Sorry, and good catch,
| posted 07 Apr, 2016 03:38
Thanks, Dan.

I made the changes and everything works perfectly now.

Login to post a reply.