The official website of the HHMI Science Education Alliance-Phage Hunters Advancing Genomics and Evolutionary Science program.

Welcome to the forums at Please feel free to ask any questions related to the SEA-PHAGES program. Any logged-in user may post new topics and reply to existing topics. If you'd like to see a new forum created, please contact us using our form or email us at

SEA-PHAGES Virtual Machine Error message

| posted 19 Sep, 2017 17:00
I am getting an error message (different than the one posted in the forum last year - see attachment). If I click on either "report" or "cancel" it kicks me back to the screen that asks for a password. The error box moves a little within the upper left corner of my screen - almost blinking in and out. I've tried to reinstall the software and I've also updated the virtual machine. Neither made a difference. Any help someone can give me is most welcome!
| posted 21 Sep, 2017 16:14
Few things to try and report back:

1. Can you ignore the box, and just start phamerator?

2. What happens if you just click the red close button at the very top left? Does it still kick you back to the login screen?

3. Does this happen on both the student and faculty accounts?
Edited 21 Sep, 2017 16:15
| posted 21 Sep, 2017 18:00

1. Can you ignore the box, and just start phamerator?

I don't think I can do that. I tried starting the virtual box and then the sea machine. I also tried starting the sea machine directly. When I start the sea machine directly I get the message in the attachment.

2. What happens if you just click the red close button at the very top left? Does it still kick you back to the login screen?

Yup. It still kicks me out.

3. Does this happen on both the student and faculty accounts?

Unfortunately yes. In the student account I can't even try to click any buttons. It kicks me back to the login screen almost immediately.
| posted 22 Sep, 2017 16:27
Too bad none of the easy work arounds helped.
I am going to assume that there are no important files inside the SEA VM, do NOT do the following if there are important files you need to recover from inside the VM. If you have files to recover you are going to need local expert who can work with your computer to get Ubuntu to boot so the files can be recovered, could be a long and arduous trial and error process of fixing Ubuntu.

So assuming there are no files to recover, I would try to fix it by simply deleting and replacing the SEA VM. Sorry I don't use Virtualbox in Windows so some of this might be a little off but should suffice:

1. Open virtualBox program so you get something like this window (i think the pic is from mac, the windows version should look similar):

2. click on the "2017 SEA VM" in the left column and select "Remove…" from the machine menu
3. You should see a message about how you are "about to remove a machine from the machine list" and three buttons. Select "Delete all files" to completely remove and delete the SEA VM and all associated files
4. Go back to and start with step two to reinstall the SEA VM, booting into Ubuntu and installing the guest additions.
| posted 22 Sep, 2017 19:24
Problem solved! Thank you so very much!!
| posted 28 Sep, 2020 04:31
My student has an issue with her virtual box.

Every time she opens up her virtual box, it won’t let her scale up to the full windows screen (see attachment). She is unable to change the settings and can't log in.
She tried to set it up again and that didn't work. It won't let her sign in and she cannot access her windows. Not sure if someone has had the same issue or knows how to fix it?
| posted 28 Sep, 2020 14:46
Hi Jasmin,

Those sorts of issues are usually related to the Guest Additions either not being installed or not being up to date. That said, it's not easy to install the Guest Additions if you can't even log into Windows. If she can log into Windows, then once she's in she should go to the Virtual Box menu Devices –> Insert Guest Additions CD Image, then follow the prompts on the Windows screen to install the Guest Additions. Often, until those are installed, the virtual machine won't work seamlessly with your host computer. (You won't be able to resize, or drag and drop, etc.)

| posted 28 Sep, 2020 15:27
Thank you! I'll let her know smile
| posted 09 Sep, 2021 17:34
I received a new computer this summer, and am currently trying to install the 2017VM.
I thought I was good to go, but when I launch the VM I get an error: attempt to read or write outside of disk 'hdo'

Does anyone know how to fix this?
| posted 13 Sep, 2021 18:04
That looks like a very low level issue with the disk device drivers. Very difficult to troubleshoot without a lot more details or direct access to your machine. I would try deleting this machine and rebuilding. You could also try the newer SEA 2020 VM. The good thing about that 2020 VM is it has the new pdm_utils installed. I don't know if I am allowed to post the link to the VM disk image in the open. Feel free to email and I can send you the link.
Edited 13 Sep, 2021 18:04
Login to post a reply.